Информация

"4admins.ru" Рекомендует

проблема с 610 NM

Графическое оформление, Шаблоны (html), темы (css), логотипы, картинки, смайлики и другое.
  • Автор 
    Сообщение
Аватара пользователя
Сообщения: 7022
Зарегистрирован: 11 авг 2009, 16:58
Благодарил (а): 655
Поблагодарили: 2342 раз в 1742 сообщениях
Город: Москва
Пол: Мужской
Адрес форума: http://help.4admins.ru
Баллы репутации: 167

проблема с 610 NM

Сообщение Добавлено: 22 сен 2009, 09:41

Автор стиля 610nm и его производных допустили маленькую ошибку из-за которой форум кажется перекошенным
Изображение
как же заставить таблицу форума стать ровной?
Идем: администраторский раздел==стили==шаблоны-==выбираем нужный стиль==выбираем шаблон forumlist_body.html ищем в нем
Код: Выделить всё
<td class="row2" align="center" nowrap="nowrap">
и удаляем
Код: Выделить всё
nowrap="nowrap"

должно стать
Код: Выделить всё
<td class="row2" align="center">

сохраняем шаблон и получаем ровный и красивый форум
Изображение
данное подходит и для некоторых других стилей
Последний раз редактировалось GoDFaTHeR 16 мар 2010, 15:50, всего редактировалось 2 раз(а).
Причина: Исправлена ошибка в имени шаблона
На этом сервисе можно cоздать форум бесплатно

За это сообщение пользователя GoDFaTHeR поблагодарили:
anya, Loveaction, SanyaFox, Shans, Silver

Аватара пользователя
Сообщения: 500
Зарегистрирован: 27 авг 2010, 17:39
Благодарил (а): 471
Поблагодарили: 56 раз в 52 сообщениях
Пол: Женский
Адрес форума: http://transalternativa.ru/
Баллы репутации: 9

Re: проблема с 610 NM

Сообщение Добавлено: 22 янв 2011, 09:00

[quoteem="GoDFaTHeR"]данное подходит и для некоторых других стилей[/quoteem]
Опробовано на 610nm_azul и redsilver3... Работает...

Аватара пользователя
Сообщения: 132
Зарегистрирован: 10 дек 2010, 15:10
Благодарил (а): 67
Поблагодарили: 9 раз в 5 сообщениях
Город: Каменск-Уральский
Пол: Женский
Адрес форума: http://dekabristki.ru/
Баллы репутации: 1

Re: проблема с 610 NM

Сообщение Добавлено: 23 июн 2011, 21:47

Я уже один раз исправляла в шаблоне своего стиля эту ошибку и она опять появилась
Изображение

Вот измененный шаблон:
Код: Выделить всё
<!-- BEGIN forumrow -->

<!-- IF (forumrow.S_IS_CAT and not forumrow.S_FIRST_ROW) or forumrow.S_NO_CAT  -->
</table>
<br />
<!-- ENDIF -->

<!-- IF forumrow.S_IS_CAT or forumrow.S_FIRST_ROW  or forumrow.S_NO_CAT  -->
<table class="tablebg" cellspacing="1" width="100%">
<tr>
   <th colspan="2">&nbsp;<!-- IF forumrow.S_IS_CAT --><a href="{forumrow.U_VIEWFORUM}">{forumrow.FORUM_NAME}</a><!-- ELSE -->{L_FORUM}<!-- ENDIF -->&nbsp;</th>
   <th width="50">&nbsp;{L_TOPICS}&nbsp;</th>
   <th width="50">&nbsp;{L_POSTS}&nbsp;</th>
   <th>&nbsp;{L_LAST_POST}&nbsp;</th>
</tr>
<!-- ENDIF -->
   <!-- IF forumrow.S_IS_CAT -->
   <!-- ELSEIF forumrow.S_IS_LINK -->
      <tr>
         <td class="row1" width="50" align="center">{forumrow.FORUM_FOLDER_IMG}</td>
         <td class="row1">
            <!-- IF forumrow.FORUM_IMAGE -->
               <div style="float: {S_CONTENT_FLOW_BEGIN}; margin-{S_CONTENT_FLOW_END}: 5px;">{forumrow.FORUM_IMAGE}</div><div style="float: {S_CONTENT_FLOW_BEGIN};">
            <!-- ENDIF -->
            <a class="forumlink" href="{forumrow.U_VIEWFORUM}">{forumrow.FORUM_NAME}</a>
            <p class="forumdesc">{forumrow.FORUM_DESC}</p>
            <!-- IF forumrow.FORUM_IMAGE --></div><!-- ENDIF -->
         </td>
         <!-- IF forumrow.CLICKS -->
            <td class="row2" colspan="3" align="center"><span class="genmed">{L_REDIRECTS}: {forumrow.CLICKS}</span></td>
         <!-- ELSE -->
            <td class="row2" colspan="3" align="center">&nbsp;</td>
         <!-- ENDIF -->
      </tr>
   <!-- ELSE -->
      <!-- IF forumrow.S_NO_CAT -->
         <tr>
            <td class="cat" colspan="2"><h4>{L_FORUM}</h4></td>
            <td class="catdiv" colspan="3">&nbsp;</td>
         </tr>
      <!-- ENDIF -->
      <tr>
         <td class="row1" width="50" align="center">{forumrow.FORUM_FOLDER_IMG}</td>
         <td class="row1" width="100%">
            <!-- IF forumrow.FORUM_IMAGE -->
               <div style="float: {S_CONTENT_FLOW_BEGIN}; margin-{S_CONTENT_FLOW_END}: 5px;">{forumrow.FORUM_IMAGE}</div><div style="float: {S_CONTENT_FLOW_BEGIN};">
            <!-- ENDIF -->
            <a class="forumlink" href="{forumrow.U_VIEWFORUM}">{forumrow.FORUM_NAME}</a>
            <p class="forumdesc">{forumrow.FORUM_DESC}</p>
            <!-- IF forumrow.MODERATORS -->
               <p class="forumdesc"><strong>{forumrow.L_MODERATOR_STR}:</strong> {forumrow.MODERATORS}</p>
            <!-- ENDIF -->
            <!-- IF forumrow.SUBFORUMS and forumrow.S_LIST_SUBFORUMS -->
               <p class="forumdesc"><strong>{forumrow.L_SUBFORUM_STR}</strong> {forumrow.SUBFORUMS}</p>
            <!-- ENDIF -->
            <!-- IF forumrow.FORUM_IMAGE --></div><!-- ENDIF -->
         </td>
         <td class="row2" align="center"><p class="topicdetails">{forumrow.TOPICS}</p></td>
         <td class="row2" align="center"><p class="topicdetails">{forumrow.POSTS}</p></td>
         <td class="row2" align="center" >
            <!-- IF forumrow.LAST_POST_TIME -->
            <!-- IF forumrow.ALTT_LINK_NAME_SHORT --><p><a <!-- IF forumrow.ALTT_STYLE_BOLD or forumrow.ALTT_STYLE_ITALIC or forumrow.ALTT_STYLE_ADV -->style="<!-- IF forumrow.ALTT_STYLE_BOLD -->font-weight: bold;<!-- ENDIF --><!-- IF forumrow.ALTT_STYLE_ITALIC -->font-style: italic;<!-- ENDIF --> <!-- IF forumrow.ALTT_STYLE_ADV -->{forumrow.ALTT_STYLE_ADV2}<!-- ENDIF -->"<!-- ENDIF --> href="{forumrow.U_ALTT_LINK}" title="{forumrow.ALTT_LINK_NAME}">{forumrow.ALTT_LINK_NAME_SHORT}</a></p><!-- ENDIF -->
               <p class="topicdetails">{forumrow.LAST_POST_TIME}</p>
               <p class="topicdetails">{forumrow.LAST_POSTER_FULL}
                  <!-- IF not S_IS_BOT --><a href="{forumrow.U_LAST_POST}">{LAST_POST_IMG}</a><!-- ENDIF -->
               </p>
            <!-- ELSE -->
               <p class="topicdetails">{L_NO_POSTS}</p>
            <!-- ENDIF -->
         </td>
      </tr>
   <!-- ENDIF -->
   
<!-- IF forumrow.S_LAST_ROW -->
</table>
<br />
<!-- ENDIF -->
<!-- BEGINELSE -->
<p>{L_NO_FORUMS}</p>

<!-- END forumrow -->

Аватара пользователя
Сообщения: 132
Зарегистрирован: 10 дек 2010, 15:10
Благодарил (а): 67
Поблагодарили: 9 раз в 5 сообщениях
Город: Каменск-Уральский
Пол: Женский
Адрес форума: http://dekabristki.ru/
Баллы репутации: 1

Re: проблема с 610 NM

Сообщение Добавлено: 24 июн 2011, 12:52

Снимаю вопрос,сегодня с форумом все в порядке.

Аватара пользователя
Сообщения: 7022
Зарегистрирован: 11 авг 2009, 16:58
Благодарил (а): 655
Поблагодарили: 2342 раз в 1742 сообщениях
Город: Москва
Пол: Мужской
Адрес форума: http://help.4admins.ru
Баллы репутации: 167

Re: проблема с 610 NM

Сообщение Добавлено: 24 июн 2011, 19:06

Модница писал(а):Я уже один раз исправляла в шаблоне своего стиля эту ошибку и она опять появилась

это уже проблема другого плана, в модификации название темы, укажите максимальное количество отображаемых символов

Заголовок последней темы форума
Настройки
Число показываемых на странице букв:
у нас стоит 25 (оптимальный вариант)
На этом сервисе можно cоздать форум бесплатно

За это сообщение пользователя GoDFaTHeR поблагодарили:
Модница

Аватара пользователя
Сообщения: 132
Зарегистрирован: 10 дек 2010, 15:10
Благодарил (а): 67
Поблагодарили: 9 раз в 5 сообщениях
Город: Каменск-Уральский
Пол: Женский
Адрес форума: http://dekabristki.ru/
Баллы репутации: 1

Re: проблема с 610 NM

Сообщение Добавлено: 24 июн 2011, 21:38

в модификации название темы, укажите максимальное количество отображаемых символов

Не могу сообразить где эти настройки :unknown

Аватара пользователя
Сообщения: 222
Зарегистрирован: 05 июл 2010, 23:05
Благодарил (а): 135
Поблагодарили: 41 раз в 35 сообщениях
Пол: Мужской
Адрес форума: .....
Баллы репутации: 16

Re: проблема с 610 NM

Сообщение Добавлено: 24 июн 2011, 21:52

Модница
Модули>Заголовок последней темы форума>Настройки>Число показываемых на странице букв

За это сообщение пользователя nar200 поблагодарили:
Модница

Аватара пользователя
Сообщения: 132
Зарегистрирован: 10 дек 2010, 15:10
Благодарил (а): 67
Поблагодарили: 9 раз в 5 сообщениях
Город: Каменск-Уральский
Пол: Женский
Адрес форума: http://dekabristki.ru/
Баллы репутации: 1

Re: проблема с 610 NM

Сообщение Добавлено: 24 июн 2011, 22:12

Всем спасибо! :privet:

Аватара пользователя
Сообщения: 52
Зарегистрирован: 11 дек 2011, 23:50
Благодарил (а): 22
Поблагодарили: 13 раз в 10 сообщениях
Пол: Мужской
Адрес форума: http://GenderQueers.info
Баллы репутации: 2

Re: проблема с 610 NM

Сообщение Добавлено: 11 фев 2012, 19:41

Почему-то у меня в стиле 610nm_azul ширина поля автора сообщения не стандартная для всех, а зависит от наличия аватары и от ее ширины. Это можно как-нибудь исправить?
На картинке разница в ширине показана красными стрелками:

Изображение
Если вы обнаружили себя на стороне большинства - вам пора на другую сторону © Марк Твен

http://GenderQueers.info - вне рамок гендера

Аватара пользователя
антивирус
антивирус
Сообщения: 605
Зарегистрирован: 25 дек 2011, 03:00
Благодарил (а): 83
Поблагодарили: 119 раз в 98 сообщениях
Город: Царицын
Пол: Мужской
Адрес форума: http://forum.sdmon.ru/
Баллы репутации: 23

Re: проблема с 610 NM

Сообщение Добавлено: 11 фев 2012, 20:55

+1!
Изображение
Изображение


Вернуться в Оформление Форума

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1